using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+,)*(\w+)\s+(\w+\d{6},)*(\w*\d{6})";
string input = @"山东大学古籍所,山东大学古籍所,山东大学古籍 所,山东大学古籍所 山东济南250100,山东济南250100,山东济南250100,山东济南250100";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}