package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+,)*(\w+)\s+(\w+\d{6},)*(\w*\d{6})`)
var str = `山东大学古籍所,山东大学古籍所,山东大学古籍所,山东大学古籍所 山东济南250100,山 东济南250100,山东济南250100,山东济南250100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}