re = /(\w+,)*(\w+)\s+(\w+\d{6},)*(\w*\d{6})/m
str = '山东大学古籍所,山东大学古籍所,山东大学古籍所,山东大学古籍所 山东济南250100,山东济南250100,山东济南250100,山东济南250100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end