$re = '/^(?:0|\s?)[1-79](?:[\.\-\s]?\d\d){4}$/';
$str = '05-59-84-14-18
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);