const regex = /^(?:0|\s?)[1-79](?:[\.\-\s]?\d\d){4}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:0|\\s?)[1-79](?:[\\.\\-\\s]?\\d\\d){4}$', '')
const str = `05-59-84-14-18
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}