using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:0|\s?)[1-79](?:[\.\-\s]?\d\d){4}$";
string input = @"05-59-84-14-18
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}