package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:0|\s?)[1-79](?:[\.\-\s]?\d\d){4}$`)
var str = `05-59-84-14-18
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}