use strict;
my $str = '0 coralxib42 0 coralxib42-ib0 - MEMBER
1 coralxib43 0 coralxib43-ib0 - MEMBER
128 coralxib44 0 coralxib44-ib0 - CF
129 coralxib45 0 coralxib45-ib0 - CF
0 coralpib241 0 - - MEMBER
1 coralpib242 0 - - MEMBER
128 coralpib243 0 - - CF
129 coralpib244 0 - - CF
cskd;ksd ksalkd;lksakd sad\'lj
020 - 29
0 coralpib241 0
1 coralpib242 0
128 coralpib243 0
129 coralpib244 0';
my $regex = qr/[0-9]+[ \t\r]+(\w|\.|\-)+[ \t\r]+[0-9]+([ \t\r]+(\w|\.|\-)+[ \t\r]+\-[ \t\r]+\w+|)(\n|\r|)+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}