#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9]+[ \t\r]+(\w|\.|\-)+[ \t\r]+[0-9]+([ \t\r]+(\w|\.|\-)+[ \t\r]+\-[ \t\r]+\w+|)(\n|\r|)+"
Local $sString = "0 coralxib42 0 coralxib42-ib0 - MEMBER" & @CRLF & _
"1 coralxib43 0 coralxib43-ib0 - MEMBER" & @CRLF & _
"128 coralxib44 0 coralxib44-ib0 - CF" & @CRLF & _
"129 coralxib45 0 coralxib45-ib0 - CF" & @CRLF & _
"0 coralpib241 0 - - MEMBER" & @CRLF & _
"1 coralpib242 0 - - MEMBER" & @CRLF & _
"128 coralpib243 0 - - CF" & @CRLF & _
"129 coralpib244 0 - - CF" & @CRLF & _
"cskd;ksd ksalkd;lksakd sad'lj" & @CRLF & _
"020 - 29 " & @CRLF & _
"0 coralpib241 0" & @CRLF & _
"1 coralpib242 0" & @CRLF & _
"128 coralpib243 0" & @CRLF & _
"129 coralpib244 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")