const regex = /[0-9]+[ \t\r]+(\w|\.|\-)+[ \t\r]+[0-9]+([ \t\r]+(\w|\.|\-)+[ \t\r]+\-[ \t\r]+\w+|)(\n|\r|)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+[ \\t\\r]+(\\w|\\.|\\-)+[ \\t\\r]+[0-9]+([ \\t\\r]+(\\w|\\.|\\-)+[ \\t\\r]+\\-[ \\t\\r]+\\w+|)(\\n|\\r|)+', 'g')
const str = `0 coralxib42 0 coralxib42-ib0 - MEMBER
1 coralxib43 0 coralxib43-ib0 - MEMBER
128 coralxib44 0 coralxib44-ib0 - CF
129 coralxib45 0 coralxib45-ib0 - CF
0 coralpib241 0 - - MEMBER
1 coralpib242 0 - - MEMBER
128 coralpib243 0 - - CF
129 coralpib244 0 - - CF
cskd;ksd ksalkd;lksakd sad'lj
020 - 29
0 coralpib241 0
1 coralpib242 0
128 coralpib243 0
129 coralpib244 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}