import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+[ \\t\\r]+(\\w|\\.|\\-)+[ \\t\\r]+[0-9]+([ \\t\\r]+(\\w|\\.|\\-)+[ \\t\\r]+\\-[ \\t\\r]+\\w+|)(\\n|\\r|)+";
final String string = "0 coralxib42 0 coralxib42-ib0 - MEMBER\n"
+ "1 coralxib43 0 coralxib43-ib0 - MEMBER\n"
+ "128 coralxib44 0 coralxib44-ib0 - CF\n"
+ "129 coralxib45 0 coralxib45-ib0 - CF\n"
+ "0 coralpib241 0 - - MEMBER\n"
+ "1 coralpib242 0 - - MEMBER\n"
+ "128 coralpib243 0 - - CF\n"
+ "129 coralpib244 0 - - CF\n"
+ "cskd;ksd ksalkd;lksakd sad'lj\n"
+ "020 - 29 \n"
+ "0 coralpib241 0\n"
+ "1 coralpib242 0\n"
+ "128 coralpib243 0\n"
+ "129 coralpib244 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}