$re = '/(?P<Spring>Spring\.)(?P<FunctionName>[a-zA-Z0-9]+)([^\(]+\()(?P<Arguments>([^\)]+))\)([^>]+>)(?P<ReturnType>[^\n]+)/';
$str = 'Spring.GetVectorFromHeading
( number heading ,test value)
-> ReturnType ReturnName
converted into
$Spring$FunctionName = function $FunctionName($Arguments) assert($Arguments); return $ReturnType end
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);