import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<Spring>Spring\\.)(?P<FunctionName>[a-zA-Z0-9]+)([^\\(]+\\()(?P<Arguments>([^\\)]+))\\)([^>]+>)(?P<ReturnType>[^\\n]+)";
final String string = "Spring.GetVectorFromHeading\n\n"
+ " ( number heading ,test value)\n\n"
+ "-> ReturnType ReturnName\n\n"
+ "converted into\n\n"
+ "$Spring$FunctionName = function $FunctionName($Arguments) assert($Arguments); return $ReturnType end\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}