#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<Spring>Spring\.)(?P<FunctionName>[a-zA-Z0-9]+)([^\(]+\()(?P<Arguments>([^\)]+))\)([^>]+>)(?P<ReturnType>[^\n]+)"
Local $sString = "Spring.GetVectorFromHeading" & @CRLF & _
"" & @CRLF & _
" ( number heading ,test value)" & @CRLF & _
"" & @CRLF & _
"-> ReturnType ReturnName" & @CRLF & _
"" & @CRLF & _
"converted into" & @CRLF & _
"" & @CRLF & _
"$Spring$FunctionName = function $FunctionName($Arguments) assert($Arguments); return $ReturnType end" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")