using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<Spring>Spring\.)(?P<FunctionName>[a-zA-Z0-9]+)([^\(]+\()(?P<Arguments>([^\)]+))\)([^>]+>)(?P<ReturnType>[^\n]+)";
string input = @"Spring.GetVectorFromHeading
( number heading ,test value)
-> ReturnType ReturnName
converted into
$Spring$FunctionName = function $FunctionName($Arguments) assert($Arguments); return $ReturnType end
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}