const regex = /( *(((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|((') *.+ *('))|((") *.+ *("))))?( *\]))*)|(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|((') *.+ *('))|((") *.+ *("))))?( *\]))+)((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))*(( +|( *[,~>+] *))(((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|(' *.+ *')|((") *.+ *("))))?( *\]))*)|(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|((') *.+ *('))|((") *.+ *("))))?( *\]))+))*)* *(?!.))/gy;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('( *(((([a-zA-Z]+)|([.#](\\w|\\w+-+\\w*)+)|(:(\\w+(-\\w+)+)(\\([a-zA-Z0-9]+\\))?)|(:{2}(\\w+(-\\w+)+))|(\\*))(\\[ *\\w+ *(([\\^$|~*]?= *)?((\\w|\\w+-+\\w*)+|((\\\\\') *.+ *(\\\\\'))|((\\\\") *.+ *(\\\\"))|((\') *.+ *(\'))|((") *.+ *("))))?( *\\]))*)|(\\[ *\\w+ *(([\\^$|~*]?= *)?((\\w|\\w+-+\\w*)+|((\\\\\') *.+ *(\\\\\'))|((\\\\") *.+ *(\\\\"))|((\') *.+ *(\'))|((") *.+ *("))))?( *\\]))+)((([a-zA-Z]+)|([.#](\\w|\\w+-+\\w*)+)|(:(\\w+(-\\w+)+)(\\([a-zA-Z0-9]+\\))?)|(:{2}(\\w+(-\\w+)+))|(\\*))*(( +|( *[,~>+] *))(((([a-zA-Z]+)|([.#](\\w|\\w+-+\\w*)+)|(:(\\w+(-\\w+)+)(\\([a-zA-Z0-9]+\\))?)|(:{2}(\\w+(-\\w+)+))|(\\*))(\\[ *\\w+ *(([\\^$|~*]?= *)?((\\w|\\w+-+\\w*)+|((\\\\\') *.+ *(\\\\\'))|((\\\\") *.+ *(\\\\"))|(\' *.+ *\')|((") *.+ *("))))?( *\\]))*)|(\\[ *\\w+ *(([\\^$|~*]?= *)?((\\w|\\w+-+\\w*)+|((\\\\\') *.+ *(\\\\\'))|((\\\\") *.+ *(\\\\"))|((\') *.+ *(\'))|((") *.+ *("))))?( *\\]))+))*)* *(?!.))', 'gy')
const str = `:pseudo-class(value)[attribute~=value]#id.class > ::pseudo-element, element`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);