# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/( *(((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|((') *.+ *('))|((") *.+ *("))))?( *\]))*)|(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|((') *.+ *('))|((") *.+ *("))))?( *\]))+)((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))*(( +|( *[,~>+] *))(((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|(' *.+ *')|((") *.+ *("))))?( *\]))*)|(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|((') *.+ *('))|((") *.+ *("))))?( *\]))+))*)* *(?!.))//gy;t' <<< ":pseudo-class(value)[attribute~=value]#id.class > ::pseudo-element, element"