re = /( *(((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|((') *.+ *('))|((") *.+ *("))))?( *\]))*)|(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|((') *.+ *('))|((") *.+ *("))))?( *\]))+)((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))*(( +|( *[,~>+] *))(((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|(' *.+ *')|((") *.+ *("))))?( *\]))*)|(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\") *.+ *(\\"))|((') *.+ *('))|((") *.+ *("))))?( *\]))+))*)* *(?!.))/
str = ':pseudo-class(value)[attribute~=value]#id.class > ::pseudo-element, element'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result