using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( *(((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\"") *.+ *(\\""))|((') *.+ *('))|(("") *.+ *(""))))?( *\]))*)|(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\"") *.+ *(\\""))|((') *.+ *('))|(("") *.+ *(""))))?( *\]))+)((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))*(( +|( *[,~>+] *))(((([a-zA-Z]+)|([.#](\w|\w+-+\w*)+)|(:(\w+(-\w+)+)(\([a-zA-Z0-9]+\))?)|(:{2}(\w+(-\w+)+))|(\*))(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\"") *.+ *(\\""))|(' *.+ *')|(("") *.+ *(""))))?( *\]))*)|(\[ *\w+ *(([\^$|~*]?= *)?((\w|\w+-+\w*)+|((\\') *.+ *(\\'))|((\\"") *.+ *(\\""))|((') *.+ *('))|(("") *.+ *(""))))?( *\]))+))*)* *(?!.))";
string substitution = @"";
string input = @":pseudo-class(value)[attribute~=value]#id.class > ::pseudo-element, element";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}