re = /\s*([a-zA-Z])(?(?=\S*?[qwrtpsdfghjklzxcvbnmQWRTPSDFGHJKLZXCVBNM]\S)(?:\S*?)([qwrtpsdfghjklzxcvbnmQWRTPSDFGHJKLZXCVBNM])|([eyuioaEYUIOA]))?[a-zA-Z]*?([a-zA-Z])?[-\?\.,\s+]/
str = 'I am. Now this is not the end. It is not even the beginning of the end. But it is, perhaps, the end of the beginning ## philosophy.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end