const regex = /\s*([a-zA-Z])(?(?=\S*?[qwrtpsdfghjklzxcvbnmQWRTPSDFGHJKLZXCVBNM]\S)(?:\S*?)([qwrtpsdfghjklzxcvbnmQWRTPSDFGHJKLZXCVBNM])|([eyuioaEYUIOA]))?[a-zA-Z]*?([a-zA-Z])?[-\?\.,\s+]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*([a-zA-Z])(?(?=\\S*?[qwrtpsdfghjklzxcvbnmQWRTPSDFGHJKLZXCVBNM]\\S)(?:\\S*?)([qwrtpsdfghjklzxcvbnmQWRTPSDFGHJKLZXCVBNM])|([eyuioaEYUIOA]))?[a-zA-Z]*?([a-zA-Z])?[-\\?\\.,\\s+]', 'g')
const str = `I am. Now this is not the end. It is not even the beginning of the end. But it is, perhaps, the end of the beginning ## philosophy.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}