using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*([a-zA-Z])(?(?=\S*?[qwrtpsdfghjklzxcvbnmQWRTPSDFGHJKLZXCVBNM]\S)(?:\S*?)([qwrtpsdfghjklzxcvbnmQWRTPSDFGHJKLZXCVBNM])|([eyuioaEYUIOA]))?[a-zA-Z]*?([a-zA-Z])?[-\?\.,\s+]";
string input = @"I am. Now this is not the end. It is not even the beginning of the end. But it is, perhaps, the end of the beginning ## philosophy.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}