import Foundation
let pattern = ##"^((http(s)?):\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://www.test.com/
https://www.test.com/
https://test.com/
https://test.com
https://www.test.com/
https://www.test.com/directory/
https://www.test.com/directory/
https://www.test.com/directory/directory/
https://www.test.com/directory/directory/
www.test.net/
http://www.test.net/
https://www.test.net/
https://www.test.net/directory/
https://www.test.net/directory/directory/directory
test.org/
www.test.net
www.test.gov
www.test.gov/
test.gov/
www.test.org
www.test.com/
http://www.test.com/
https://www.test.com/directory/news-events/index.html?date=2013-05-01
https://test.test.com/directory/news-events/index.html?date=2013-07-07
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)