$re = '/^((http(s)?):\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$/mi';
$str = 'https://www.test.com/
https://www.test.com/
https://test.com/
https://test.com
https://www.test.com/
https://www.test.com/directory/
https://www.test.com/directory/
https://www.test.com/directory/directory/
https://www.test.com/directory/directory/
www.test.net/
http://www.test.net/
https://www.test.net/
https://www.test.net/directory/
https://www.test.net/directory/directory/directory
test.org/
www.test.net
www.test.gov
www.test.gov/
test.gov/
www.test.org
www.test.com/
http://www.test.com/
https://www.test.com/directory/news-events/index.html?date=2013-05-01
https://test.test.com/directory/news-events/index.html?date=2013-07-07';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);