use strict;
my $str = 'https://www.test.com/
https://www.test.com/
https://test.com/
https://test.com
https://www.test.com/
https://www.test.com/directory/
https://www.test.com/directory/
https://www.test.com/directory/directory/
https://www.test.com/directory/directory/
www.test.net/
http://www.test.net/
https://www.test.net/
https://www.test.net/directory/
https://www.test.net/directory/directory/directory
test.org/
www.test.net
www.test.gov
www.test.gov/
test.gov/
www.test.org
www.test.com/
http://www.test.com/
https://www.test.com/directory/news-events/index.html?date=2013-05-01
https://test.test.com/directory/news-events/index.html?date=2013-07-07';
my $regex = qr/^((http(s)?):\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}