// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^((http(s)?):\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$").unwrap();
let string = "https://www.test.com/
https://www.test.com/
https://test.com/
https://test.com
https://www.test.com/
https://www.test.com/directory/
https://www.test.com/directory/
https://www.test.com/directory/directory/
https://www.test.com/directory/directory/
www.test.net/
http://www.test.net/
https://www.test.net/
https://www.test.net/directory/
https://www.test.net/directory/directory/directory
test.org/
www.test.net
www.test.gov
www.test.gov/
test.gov/
www.test.org
www.test.com/
http://www.test.com/
https://www.test.com/directory/news-events/index.html?date=2013-05-01
https://test.test.com/directory/news-events/index.html?date=2013-07-07";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}