use strict;
my $str = '- , . \' & /
abcdefghijklmopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVW
1234567890
_[]"\\?<>!@#$%^*()
áäâàæãåāçéëêèęėēíïìîįīj́ñńóöôòõœøōúüûùū
ÁÄÂÀÆÃÅĀÇÉËÊÈĘĖĒÍÏÌÎĮĪJ́ÑŃÓÖÔÒÕŒØŌÚÜÛÙŪ
Paradijslaan
64
B
3034 SP
Rotterdam
Luxemburgstraat
41
A
1363 BK
Almere
Klarinet
6
5231 DL
\'s-HertogenboschNoordstraat
42-a
5038 EJ
Tilburg';
my $regex = qr/[a-zA-Z\À-ž\d\s.',/-]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}