import Foundation
let pattern = #"(?i)insuficiencia[\s]{0,3}hep[Ááa]tica|fall[ao](.){0,9}funci[Óóo]n[\s]{0,3}hep[Ááa]tica|descompensaci[Óóo][\s]{0,3}hep[Ááa]tica|descompensaci[Óóo]n[\s]{0,3}hep[Ááa]tica|fall[oa][\s]{0,3}hep[Ááa]tic[ao]|disfunci[Óóo]n[\s]{0,3}hep[Ááa]tica|deterioro(.){0,8}funci[Óóo]n[\s]hep[Ááa]tica"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
insuficiencia hepática
falla de la función hepática
fallo de funcion hepatica
fallo de funcion hepÁtica
descompensación hepática
falla hepática
fallo hepatico
disfuncion hepatica
deterioro de la funcion hepatica
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)