using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)insuficiencia[\s]{0,3}hep[Ááa]tica|fall[ao](.){0,9}funci[Óóo]n[\s]{0,3}hep[Ááa]tica|descompensaci[Óóo][\s]{0,3}hep[Ááa]tica|descompensaci[Óóo]n[\s]{0,3}hep[Ááa]tica|fall[oa][\s]{0,3}hep[Ááa]tic[ao]|disfunci[Óóo]n[\s]{0,3}hep[Ááa]tica|deterioro(.){0,8}funci[Óóo]n[\s]hep[Ááa]tica";
string input = @"insuficiencia hepática
falla de la función hepática
fallo de funcion hepatica
fallo de funcion hepÁtica
descompensación hepática
falla hepática
fallo hepatico
disfuncion hepatica
deterioro de la funcion hepatica
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}