// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)insuficiencia[\s]{0,3}hep[Ááa]tica|fall[ao](.){0,9}funci[Óóo]n[\s]{0,3}hep[Ááa]tica|descompensaci[Óóo][\s]{0,3}hep[Ááa]tica|descompensaci[Óóo]n[\s]{0,3}hep[Ááa]tica|fall[oa][\s]{0,3}hep[Ááa]tic[ao]|disfunci[Óóo]n[\s]{0,3}hep[Ááa]tica|deterioro(.){0,8}funci[Óóo]n[\s]hep[Ááa]tica").unwrap();
let string = "insuficiencia hepática
falla de la función hepática
fallo de funcion hepatica
fallo de funcion hepÁtica
descompensación hepática
falla hepática
fallo hepatico
disfuncion hepatica
deterioro de la funcion hepatica
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}