re = /if\s*\((.+?)\)\s*{(.*?)}\s*?(else\s*?if\s*?\((.+?)\)\s*?{.*?})?\s*?(else\s*?{(.*?)})?/
str = 'if(condition){result }else if(condition){}else{}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end