package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`if\s*\((.+?)\)\s*{(.*?)}\s*?(else\s*?if\s*?\((.+?)\)\s*?{.*?})?\s*?(else\s*?{(.*?)})?`)
var str = `if(condition){result }else if(condition){}else{}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}