using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"if\s*\((.+?)\)\s*{(.*?)}\s*?(else\s*?if\s*?\((.+?)\)\s*?{.*?})?\s*?(else\s*?{(.*?)})?";
string input = @"if(condition){result }else if(condition){}else{}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}