#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "if\s*\((.+?)\)\s*{(.*?)}\s*?(else\s*?if\s*?\((.+?)\)\s*?{.*?})?\s*?(else\s*?{(.*?)})?"
Local $sString = "if(condition){result }else if(condition){}else{}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")