re = /^(\+|00)?33(6|7)([0-9]{8})$/m
str = '0986423268
01436464654654654
0754554565
0678866556
6078866556
336845269846685
33684526985
33784526985
0033784526985
00337845269855
003378452698
+33784526845
+33584526984
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end