# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\+|00)?33(6|7)([0-9]{8})$"
test_str = ("0986423268\n"
"01436464654654654\n"
"0754554565\n"
"0678866556\n"
"6078866556\n"
"336845269846685\n"
"33684526985\n"
"33784526985\n\n"
"0033784526985\n"
"00337845269855\n"
"003378452698\n\n"
"+33784526845\n"
"+33584526984\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.