use strict;
my $str = '0986423268
01436464654654654
0754554565
0678866556
6078866556
336845269846685
33684526985
33784526985
0033784526985
00337845269855
003378452698
+33784526845
+33584526984
';
my $regex = qr/^(\+|00)?33(6|7)([0-9]{8})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}