#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+|00)?33(6|7)([0-9]{8})$"
Local $sString = "0986423268" & @CRLF & _
"01436464654654654" & @CRLF & _
"0754554565" & @CRLF & _
"0678866556" & @CRLF & _
"6078866556" & @CRLF & _
"336845269846685" & @CRLF & _
"33684526985" & @CRLF & _
"33784526985" & @CRLF & _
"" & @CRLF & _
"0033784526985" & @CRLF & _
"00337845269855" & @CRLF & _
"003378452698" & @CRLF & _
"" & @CRLF & _
"+33784526845" & @CRLF & _
"+33584526984" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")