# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([0-1]\d:[0-5]\d)|(^20:0[0-5])"
test_str = ("00:00\n"
"01:00\n"
"02:00\n"
"03:00\n"
"04:00\n"
"05:00\n"
"06:00\n"
"07:00\n"
"08:00\n"
"09:00\n"
"10:00\n"
"11:00\n"
"12:00\n"
"12:09\n"
"12:19\n"
"12:29\n"
"12:30\n"
"12:31\n"
"12:32\n"
"12:33\n"
"12:34 \n"
"12:35 midday (all days of week)\n"
"12:36\n"
"13:00\n"
"14:00\n"
"15:00\n"
"16:00\n"
"17:00\n"
"18:00\n"
"19:00\n"
"19:35 evening (sun-fri)\n"
"20:00\n"
"20:05 evening (saturday)\n"
"20:15\n"
"20:25\n"
"20:35\n"
"21:00\n"
"22:00\n"
"23:00")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.