#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-1]\d:[0-5]\d)|(^20:0[0-5])"
Local $sString = "00:00" & @CRLF & _
"01:00" & @CRLF & _
"02:00" & @CRLF & _
"03:00" & @CRLF & _
"04:00" & @CRLF & _
"05:00" & @CRLF & _
"06:00" & @CRLF & _
"07:00" & @CRLF & _
"08:00" & @CRLF & _
"09:00" & @CRLF & _
"10:00" & @CRLF & _
"11:00" & @CRLF & _
"12:00" & @CRLF & _
"12:09" & @CRLF & _
"12:19" & @CRLF & _
"12:29" & @CRLF & _
"12:30" & @CRLF & _
"12:31" & @CRLF & _
"12:32" & @CRLF & _
"12:33" & @CRLF & _
"12:34 " & @CRLF & _
"12:35 midday (all days of week)" & @CRLF & _
"12:36" & @CRLF & _
"13:00" & @CRLF & _
"14:00" & @CRLF & _
"15:00" & @CRLF & _
"16:00" & @CRLF & _
"17:00" & @CRLF & _
"18:00" & @CRLF & _
"19:00" & @CRLF & _
"19:35 evening (sun-fri)" & @CRLF & _
"20:00" & @CRLF & _
"20:05 evening (saturday)" & @CRLF & _
"20:15" & @CRLF & _
"20:25" & @CRLF & _
"20:35" & @CRLF & _
"21:00" & @CRLF & _
"22:00" & @CRLF & _
"23:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")