const regex = /^([0-1]\d:[0-5]\d)|(^20:0[0-5])/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-1]\\d:[0-5]\\d)|(^20:0[0-5])', 'mg')
const str = `00:00
01:00
02:00
03:00
04:00
05:00
06:00
07:00
08:00
09:00
10:00
11:00
12:00
12:09
12:19
12:29
12:30
12:31
12:32
12:33
12:34
12:35 midday (all days of week)
12:36
13:00
14:00
15:00
16:00
17:00
18:00
19:00
19:35 evening (sun-fri)
20:00
20:05 evening (saturday)
20:15
20:25
20:35
21:00
22:00
23:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}