// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)(\b|[¡¿])(?<uno>[^\s]+\s[^,]+),\s(\k<uno>)([?!]|\b)").unwrap();
let string = "- Dios mÃo, ¡está aquÃ, está aquÃ!
- ¿Qué paso, qué paso?
- Me rehúso, me rehúso.";
let substitution = "$1$2$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}