import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(\\b|[¡¿])(?<uno>[^\\s]+\\s[^,]+),\\s(\\k<uno>)([?!]|\\b)";
final String string = "- Dios mÃo, ¡está aquÃ, está aquÃ!\n\n"
+ "- ¿Qué paso, qué paso?\n\n"
+ "- Me rehúso, me rehúso.";
final String subst = "$1$2$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}