# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)(\b|[¡¿])(?<uno>[^\s]+\s[^,]+),\s(\k<uno>)([?!]|\b)/$1$2$4/gm;t' <<< "- Dios mÃo, ¡está aquÃ, está aquÃ!
- ¿Qué paso, qué paso?
- Me rehúso, me rehúso."