$re = '/https:\/\/(?:www.)?vimeo.com\/([0-9]{9})(?:\#t=(\d+)s)?/i';
$str = 'https://vimeo.com/192837465
https://vimeo.com/192837465#t=130s
https://www.vimeo.com/192832789
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);