package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)https:\/\/(?:www.)?vimeo.com\/([0-9]{9})(?:\#t=(\d+)s)?`)
var str = `https://vimeo.com/192837465
https://vimeo.com/192837465#t=130s
https://www.vimeo.com/192832789
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}