const regex = /https:\/\/(?:www.)?vimeo.com\/([0-9]{9})(?:\#t=(\d+)s)?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/(?:www.)?vimeo.com\\\/([0-9]{9})(?:\\#t=(\\d+)s)?', 'gi')
const str = `https://vimeo.com/192837465
https://vimeo.com/192837465#t=130s
https://www.vimeo.com/192832789
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}