using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/(?:www.)?vimeo.com\/([0-9]{9})(?:\#t=(\d+)s)?";
string input = @"https://vimeo.com/192837465
https://vimeo.com/192837465#t=130s
https://www.vimeo.com/192832789
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}