re = /^\(01\)(?P<gtin14>[0-9]{14})\(21\)(?P<serial_number>[0-9]{1,20})\(17\)(?P<expiration_date>[0-9]{6})\(10\)(?P<lot>[a-zA-Z0-9]{1,20})/m
str = '(01)03555555345345(21)234390(17)201231(10)22654'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end