using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(01\)(?P<gtin14>[0-9]{14})\(21\)(?P<serial_number>[0-9]{1,20})\(17\)(?P<expiration_date>[0-9]{6})\(10\)(?P<lot>[a-zA-Z0-9]{1,20})";
string input = @"(01)03555555345345(21)234390(17)201231(10)22654";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}